
 

GUIDE FOR USING 
HEALTHLINK WITH MEDICAL 
DIRECTOR SOFTWARE 

 

Please note, this information sheet is part of our Secure Messaging in General Practice 

suite of resources that includes videos and instructional information for explaining how to 

use Argus, ReferralNet or Healthlink for sending patient information using encrypted 

communications.  

They are part of Western Victoria Primary Health Network’s commitment to improving 

access to and use of digital health tools in western Victoria. 

Access other resources in this series via our website: westvicphn.com.au/securemessaging 

 

Before you begin  

• Make sure you have installed the latest version of HealthLink SIX messaging system (HMS version 

6.6.x) in your system. 

• If you are unsure of anything or need assistance, please contact the HealthLink helpdesk on 1800 125 

036. 

Setting up HealthLink with MD3.14  

• The Scheduled Document Import (SDI) utility provides Medical Director with the ability to 

automatically import messages. The user can configure SDI to run at a regular interval.  

How SDI works 

• When HealthLink SIX messaging is installed, it creates an interface file called 

hms_config.xml located in the C:\HLINK directory. The interface file contains the file path 

details for all the incoming and outgoing directories for the different message types. MD3.10 

or later looks for this file on the local computer and uses the file to find the appropriate paths 

for its messages.  

  



How to turn on SDI  

• Click Tools > Manage 

Communications>General 

Tab>General  

 
 

• Select HCN Live Data for the Import Database drop down box in General tab.  

• Select the desired automatic import frequency from Automatic Import Interval drop down box.  

• Click Close to the bottom left of the screen to save the changes.  

• A pop-up screen will confirm if you would like to save the changes. Click Yes to confirm changes.  

• A screen will pop up advising that the SDI will be tested click on OK for SDI to start trial import.  

• When the test is successful Click OK.  

How to turn off SDI  

• Click Tools > Manage Communications and select (disabled) from the Import database drop down 

box.  

Setting up HealthLink imports within MD3  

Setting Up HealthLink Advance Options  

• Go to Start>All Programs> 

HealthLink Advance Options  

• Click on Configuration>User 

Settings  

• Click on Message Types Tab  

• Select LAB2 message type and click 

on Messages Stores tab on lower 

half of the screen.  

 
 

• Click the Edit/More button and change the incoming and outgoing file paths. Click the Close button 

to close the screen.  

• Make the same changes to RSDAU, PIT, and BROADCST (if in Southern Australia).  

• Click on File>Save All to save the changes made.  

• Click on File>Exit to exit out of HealthLink Advance Options.  

 



Setting up Medical Director Manage Communication  

• From the Medical Director’s main 

tool bar choose Tools > Manage 

Communication.  

• In the General Tab, look up 

Recognised File extensions list for 

REF.  

• If REF extension is not in the list, 

add .REF extension to the list.  

• Click on Setup Data Transfer tab.  

 

 

• MD3.14 will automatically look at HealthLink Interface file in C:\HLINK  

• If HealthLink Six Message was not installed on the C:\ drive then browse to the HLINK folder and 

select the HealthLink Interface file hms_config.xml  

• Click on the Refresh HealthLink Import Path(s) button to load the HealthLink settings. This will 

populate the Manage Communications settings with HealthLink file paths.  

• Click on Global check boxes for LAB2, RSDAU, PIT and BROADCST (if in Southern Australia).  

• Click on ACK boxes for, PIT and BROADCST (if in Southern Australia).  

• Click on Close button to save changes.  

NOTE: If any changes are made to HMS advanced options, refresh HealthLink import paths(s) from setup 

data transfer tab for MD3.14 to pick up the settings.  

Setting up the RSDAU messaging  

Filing Referrals, Specialist letters, Discharge Summaries  

Incoming RSD messages (Referrals, Specialist letters, Discharge Summaries) can be filed in 

Documents within a patient’s notes. Use the following steps, to set this up. 

• From the main tool bar choose 

Tools > Option, select the RSD 

tab.  

• Select File reports as Documents.  

• Click on Save. 

 

 

 



Testing your configuration  

Generating Lab 2 test messages  

• Open the HealthLink SIX Advanced Options  

• From menu click Utilities>Test Message Generator. The Test Message Generator window will 

appear.  

• Sending and receiving EDI account will automatically fill with the practice EDI.  

• To generate LAB2 messages click on LAB2 from Message Types available to you and then on 

Generate Test Message button.  

Generating RSDAU test messages  

• To generate RSDAU message click RSDAU from Message Types available to you and then click on 

Generate Test Message button.  

• Click on File and Exit to close the Healthlink Advanced Options. 

Making HealthLink connection manually  

• From system tray, right click on HealthLink Icon  

 

 

• Left click on Run Now to make the manual 

connection.  

 

 

• A spinning ‘H’ indicates the HealthLink application has 

started its connection.  

 

 

• Once the ‘H’ stops spinning, the HealthLink connection has been completed and the test messages 

are downloaded into their respective incoming folders for Medical Director to import.  

 

  

  

  



Checking Messages in MD3  

• To check message into MD3, press the F5 key or alternatively, from the MD3 menu, click 

Investigations > Check Holding File (message import is done automatically if SDI functionality is on). 

NOTE: It is advisable not to use F4 key from the keyboard to manual import, since SDI 

functionality can be scheduled to desired interval to import the diagnostic reports, referrals and 

discharge summaries automatically. 

• Select the name of the doctor for which you want 

to view the investigation results and click the OK 

button  

  

• A list of the current messages will be displayed with message preview. To get to a full preview double 

click on the message you want a full preview off. 

 

NOTE: The inbox in MD 3.14 provides the user with a options such as Assigning Reports, 

Deleting one or more messages etc from the preview screen. Message preview can be changed 

using the preview button on the top left hand corner.  

Disabling HCN Service Manager  
If the practise has started using a new clinical software system, it is possible that HCN Service Manager may 

still be running hence pulling the messages out of default Healthlink SIX messaging folders.  

To stop messages been pulled by HCN Service Manager. HCN Service Manager needs to be disabled.  

This service starts automatically and to stop this service change the startup type to ‘disabled’.  

• Click Start > Run. In the Run window 

type services.msc and click the OK 

button.  

 

 



• From the service screen look for HCN 

Service Manager and double, left 

click to open HCN Service Manager 

Properties window, as shown.  

 

 

• Select Disabled from the Startup type.  

• Click Stop from the Service status and then click the OK button.  

 

  

  

  

  

  



Setting up Address Book  

NOTE: Each Specialist or GP that you wish to send referrals to needs to have an address book entry with a 

MDX Facility ID in Medical Directory Systems. In the address book a site has a facility ID if there is an icon 

against the address details.  

Before you begin  

You will need to be registered to use MDExchange with Medical Director. You will also need to check that 

your registration includes being able to send.  

• To check, select 

Tools>MDExchange>Licence details  

 

 

• If the status does not show as registered or 

shows receive only, you will need to follow 

the on-screen registration instructions or 

contact Medical Director.  

 

Adding a New Specialist or GP to the MDExchange 
Address Book  

• Select Patient>Open (F2) you need to be 

in a patients record to add the facility ID 

(messaging address). 
 

• Search for a patient (any patient – suggest a test patient). 

• Highlight the patient and select OK.  

 

• Once you have the patient record open you will need to open a blank patient letter. You need to be in 

this area to add GPs and Specialist to the MDExchange address book. You do not need to write an 

actual letter.  



• Select Tools>Letter Writer (F8) or the 

icon. 

  

• Click File>Send via MDExchange or the 

icon. 

  

  

 

 

• Select To.  

 

 

• Select the Online Search Results tab. 

• In the Select MDExchange recipient window, enter the facility ID. The facility ID is also known as the 

EDI or Messaging Address. The facility ID is the HealthLink EDI for the provider/clinic you wish to send 

the referral to.  

• You are able to locate the EDI through HealthLink’s online database. If you do not have access, please 

call the HealthLink helpdesk on 1800 125 036.  

 

NOTE: the facility ID must be accurate to bring up the correct details.  

• Select Search. The search should bring up the information belonging to the facility ID. 

• Highlight the information displayed. 

• Double click on the highlighted name from the list. 



 

• In the Matching Addresses Found 

window, click on Add to save the 

selected provider/clinic to the local 

address book. If there is no entry in your 

address book to match the address to 

when you double-click on the highlighted 

name from the list, it will automatically 

add it to the address book.  

• This will save the details to the address 

book along with the Facility ID icon. 

  
 

 

• Once the icon appears next to the name of the site you are now able to send to that site using 

HealthLink via MDExchange.  

 

  

  

  

  

  

  

  

  

  

  

  



Creating and sending letters and 
referrals  

Before you begin  

Each Specialist or GP that you wish to send referrals to needs to have an address book entry with a MDX 

Facility ID in Medical Directory Systems. In the address book a site has a facility ID if there is an icon against 

the address details.  

You will need to be registered to use MDExchange with Medical Director. You will also need to check that 

your registration includes being able to send.  

• Select Tools>MDExchange>Licence 

Details. 

• If the status does not show as registered 

or shows ‘receive’ only, you will need to 

follow the on-screen registration 

instructions or contact Medical Director.  

 

Creating a new referral or letter  

• Select Patient>Open (F2). 

• Search for the patient you wish to send 

the referral or letter for.  

 

 

• Highlight the patient and select OK.  

 



• Select Tools > Letter Writer (F8) or the 

icon .  

• Select File > New (Ctrl +N) or the icon 

. 

 
 

• Select the name of your required templates from any of the tabs and select OK.  

 

• Complete the letter or template as required, eg adding the addressee.   

• Review your completed document. Any changes can be updated directly into the template. 

Sending your letter or referral  

Once you have finished making changes to the letter or referral, you can send your message using 

MDExchange. 

• Click on File > Send via 

MDExchange or click the icon  

located on the toolbar.  

  

 

 



• Select To.  

 

 

• Select the Address Book tab. 

• Enter the name of the provider or clinic. The sites information will be shown.  

• Highlight the recipient and select To. 

 

NOTE: If the icon does not appear next to the addressee, you will need to add them into the 

MDExchange address book. You are unable to send to this site using the HealthLink via 

MDExchange if the icon does not appear next to the address.  

• The addressee’s details should appear in the Recipients To area. 

• Select OK.  

 

• In the Send as section select Plain 

Text.  

• Select Send. 

• If you wish to add a Cc, please do so 

before you select send. See 

instructions for adding Cc in the next 

section.  

 



• You will see a bar showing the message being sent.  

• Once the message has been sent, you will be taken back to the patient’s record and it will show 

the details under the Letters tab.  

 

Adding a Cc 

• Select Cc. 

• Select the Address Book tab.  

• Enter the name of the provider or clinic. The 

sites information will be shown. 

 

 

• Highlight the recipient and select Cc.  

 

NOTE: If the icon does not appear next to the addressee you will need to add them into the MDExchange 

address book. You are unable to send to this site using the HealthLink via MDExchange if the icon does 

not appear next to the address.  

• The addressee’s details should appear in the Recipients Cc area.  

• Select OK. 

• You can add more than one Cc by repeating steps above. 



 

• Select Send.  

• You will see a bar showing the message being 

sent.  

 

 

 

• Once the message has been sent you will be taken back to the patient’s record and it will show the 

details under the Letters tab.  

 

 

Tracking sent messages  

It is important if you are sending referrals or any other types of messages, to check that they are being 

received by the recipient.  

• Once you have sent a message the 

recipient’s system will inform you by way 

of an acknowledgement. There are two 

ways of viewing the status of a patient’s 

e-referrals. Select Tools > MDExchange 

> Sent items. 

 

 

• This will show the status of all messages send including Cc’s. You can use the filters to make a more 



individualised search.  

 

• Within the patients file, select the MDExchange tab. This will show only the open patient’s e-referrals. 

This will show the status of the messages sent including any Cc’s. 

 

 The status of the referral sent will be updated as follows:  

Status Message progress 

Awaiting Transmission The message is sent to the practice server. 

Sent Referral is sent from your practice server to the MDExchange 

server. 

Transferred to HealthLink Referral is sent from MDExchange to HealthLink. 

Accepted The provider or clinic has successfully received your referral. 

Failed Transferring to HealthLink Connection between MDExchange and HealthLink has been 

unsuccessful. Contact HealthLink for further assistance. 

Rejected by HealthLink Incorrect EDI address or message failed HealthLink validation. 

Contact HealthLink for further assistance. 

 

  



Viewing incoming reports and referrals  

Message importing  

Message import is done automatically if the SDI functionality is on.  

• Select Correspondence > Check Holding File (F5).  

 

• Select the name of the doctor for which you 

want to view the correspondence. You can 

choose more than one doctor at a time by 

clicking on the doctor’s name and 

highlighting. You can also view all incoming 

correspondence by clicking on and 

highlighting All Recipients.  

• Select OK. 

 

 

NOTE: The way the sending site has the doctor entered into their address book will depend on how it 

will show up in the holding file. There may be more than one variation of the doctor’s name that 

needs to be viewed.  

• A list of the current messages will be displayed with the message preview. To get the full preview 

double click in the message.  



 

• Action correspondence as required using option bars. 

 

• Once all correspondence under the doctor’s name has been actioned, the name will no longer 

appear in the holding file.   

  

  

 


