
 

GUIDE FOR USING 
HEALTHLINK WITH BEST 
PRACTICE SOFTWARE 

 

Please note, this information sheet is part of our Secure Messaging in General Practice 

suite of resources that includes videos and instructional information for explaining how to 

use Argus, ReferralNet or Healthlink for sending patient information using encrypted 

communications.  

They are part of Western Victoria Primary Health Network’s commitment to improving 

access to and use of digital health tools in western Victoria. 

Access other resources in this series via our website: westvicphn.com.au/securemessaging 

 

Before you begin  

• Make sure you have installed the latest version of HealthLink SIX messaging system (HMS version 

6.6.x) in your system. 

• It is preferred to install Healthlink Six messaging system on the server. This will allow automated import 

of messages via BP link applet.  

• The HLINK directory described in this guide should be shared and users will need to have full 

(read/write) permissions. We advise you to use local paths when you configure the HLINK directory.  

▪ For example:  

• C:\HLINK\HL7_in\LAB2  

• C:\HLINK\HL7_in\RSDAU  

• C:\HLINK\PIT_in  

• If Healthlink is installed on a workstation, the messages need to be routed to the server to allow 

automated import of messages via BP link applet. To route the messages to sever, refer to the Routing 

Messages to Server part if this document.  

• If you are unsure on any of the above, please contact the HealthLink Helpdesk on 1800 125 036  

NOTE: If the EMR has the ability to automatically import the messages, ensure auto import works. Ensure to 

remove all inbound acknowledgments form the test message to avoid any message looping.  

  

  



Setting up Best Practice to receive diagnostic results 
and letters via Healthlink  

Results Import cannot be configured via terminal session. To configure results import logon to the server with 

administrator access.  

• From the menu, click Setup > Configuration > Results Import  

• On the Report file search paths click the Add button. Browse to and select the 

C:\HLINK\HL7_in\LAB2, C:\HLINK\PIT_in and C:\HLINK\HL7_in\RSADU folders respectively.  

• Click OK to save changes  

• In the Configuration window, click the Save button to close.  

• Use C:\HLINK\FF_in\BROADCST for Report file search path if you are in South Australia, 

Western Australia or Tasmania instead of C:\HLINK\PIT_in.  

Setting up Best Practice to acknowledge reports  

In previous versions of Best Practice, acknowledgement paths were required to be set up for each sender to 

receive a valid acknowledgement in receipt of a sent message. This set-up is no longer required for Best 

Practice version 1.7.0.503.  

The following process can be used to acknowledge letters, diagnostics results and to create patient referral 

in correct configure settings for Messaging Providers.  

• From the menu, click Setup > Configuration> Messaging. On the Messaging Providers section, 

click the Add button.  

• For the Provider name field type ‘Healthlink.  

NOTE: the spelling must be correct, no other name will work. 

• For the Path for incoming messages field, browse to and select the \\servername\HLINK\HL7_in.  

• For the Path for outgoing messages field, browse to and select the 

\\servername\HLINK\HL7_out\rsdau. 

NOTE: Outgoing message filed will often change to a default Best Practice location. Ensure to re-edit this 

section and check configuration path has saved correctly.  

• Put a tick in Use the same path on all computers.  

• For Account ID type in your own HealthLink EDI account.  

• Put a tick in Use as default messaging provider. 

• Click Save to close Messaging provider screen.  

• Click on Save on configuration screen to close configuration screen.  

  

 

 



Testing Your Configuration  

Healthlink SIX Messaging can generate test messages to test configuration. Test messages are sent to 

practice EDI to be imported into the practice clinical software to ensure all configurations are working.  

 Generating HL7 Diagnostic Results Test Messages  

• Open the HMS Advanced Options from All Programs > Healthlink SIX  

• From the menu click Utilities>Test Message Generator. The Test Message Generator window will 

appear.  

• The sending and receiving EDI account will automatically fill with the practice EDI.  

• Click on Lab2 and then on the Generate Test Message button.  

 Generating RSDAU Test Messages  

• To generate a RSDAU message click RSDAU and then click on the Generate Test Message button.  

 Making Healthlink Connection Manually  

• From the system tray right click on the Healthlink Icon  

• Left click on Run Now to make the manual connection.  

• A spinning ‘H’ indicates the Healthlink client has started its connection.  

• Once the ‘H’ stops spinning, the Healthlink connection has been completed and the test messages are 

downloaded into their respective incoming folders for Best Practice to import.  

Importing your messages into Best Practice  

There are two ways of importing messages into Best Practice.  

• Run the utility called ‘BPLink’ on the server. This utility will check every five minutes to see if there are 

any results or reports in any of the folders indicated in the ‘Report file search paths’ and if found will 

import them into Best Practice or 

• Select View > Incoming Reports from the main Best Practice screen or click the icon  

This will force an import of any results or reports found in any of the folders indicated in the ‘Report file 

search paths’ into the system.    

Checking file extensions  

Check that Best Practice has the correct file extension for incoming messages. Best Practice System is 

usually set up with default extension paths. However, it is best to confirm the correct paths are displayed 

within the outlined area. If for some reason you need to add an extension manually, please follow these 

steps.  

• Setup > Configuration>Results Import. Click Add  

• Enter the extension. Click Save.  

• This new extension will appear in the Report file extensions box.  

NOTE: Add RRI to the file extensions list. 

 



Routing messages to server  

To route the message successfully to server from a workstation where Healthlink Six is installed, the 

two import things to adhere are change mode of operation and change default file path to point to 

server.  

• Copy Hlink folder from C:\ of the workstation to C:\ of the server computer.  

• Open HMS Advance option on the workstation Start>All Programs>Healthlink Six>HMS Advance 

Options  

• Click on NT service tab to stop and uninstall Healthlink service on workstation.  

• Click on Scheduler tab and change mode of operation to Unattended Hands Free.  

• Click on Configuration>User Settings>Message Type tab  

• Change file path for Lab2, PIT, RSDAU by selecting individual message type and then clicking on 

Directories in lower part of the screen and click on Edit/More button.  

• Select and change file path of Broadcast message type if you are in South Australia, Western 

Australia or Tasmania  

• Change from C:\hlink to \\servername\hlink in all incoming and Outgoing message directory locations. 

Click on Close to go back to select another message type.  

• Once all required message type file path locations are changed, click on File and Save All to save the 

changes.  

 

  

file://///servername/hlink


Setting up Address Book  

Each specialist or GP you wish to send referrals to needs to have an address book entry in Best Practice 

Systems.  

Adding a new specialist or GP  

• Select View> Contacts (F11). 

 

 

• Select Add New on the Contacts screen.  

 

• Fill in the details for the Specialist or 

GP. 

 

• Select Add to enter the address. 

• Select Accepts CDA eReferrals.  

• Select Save and you will be taken back to the contact page. 

• In the Messaging Provider field, select HealthLink. 

• Enter the contact’s Account ID – this is 

the EDI messaging address. The EDI 

can be obtained from searching the 

HealthLink directory.  

 

 



• Once information has been entered, select Save. Your contact has now been added to your address 

book. To verify that the site is ready, highlighting the GP or Specialist and the message ‘Can receive 

eReferrals’ in green should been seen.  

 

 

Editing an existing contact  

• Select View > Contacts (F11).  

 

 

• In the search field, enter the contact you would like to edit.  

 

• Once you have located the record 

that you wish to edit, make sure it is 

highlighted. 

• Select Edit. 

 

 



• In the Messaging Provider field, 

select HealthLink.  

• Enter the contact’s Account ID – this 

is the EDI (messaging address. The 

EDI can be obtained from searching 

the HealthLink directory.  

 

 

• Highlight the address and select 

Edit.  

• Select Accepts CDA eReferrals. 

• Select Save and you will be taken 

back to the Contact Details screen. 

 

 

• Once information has been entered select Save. Your contact has now been added to your address 

book. To verify that the site is ready, highlighting the GP or Specialist and the message ‘Can receive 

eReferrals’ in green should been seen.  

 

  

  

 

  

  

  

  

  

  

  



Creating and sending letters and 
referrals 

Creating and sending a new referral or letter  

• Select File>Open Patient (F2). 

• Search for the patient. 

• Highlight and select Open or 

double click . 

 

 

• Select File>New Letter (F4) to 

create a new letter or select the 

icon.  

• Select the template required. 

 

 

• If prompted – search for the 

provider to whom will be receiving 

the referral or letter. Highlight the 

correct doctor and click Select. 

• A green star indicates that the 

contact can receive via secure 

messaging.  

 
 

• Make any changes and review 

the completed document. 

• Select Send HL7 File.  

 



• Enter any additional information 

into the Document Details screen. 

• Select Save.  

 

 

• A screen confirming that the file 

has been successfully exported to 

the outgoing HealthLink folder will 

pop up.  

• Select OK. You will be taken back 

to the letter or referral. The waiting 

letters should be sent 

automatically on your next 

scheduled HealthLink connection. 

(Default to 30 mins)  

 

• Select the  icon. You will be taken back to the patients record and the letter or referral will show in 

the Correspondence Out folder. 

 

 

  

  

  

  

  

   

 



Checking acknowledgements  

Once you have sent a message, the recipients system should inform you by way of an acknowledgement to 

let you know that the message was received successfully. It is best to wait 24 hours before checking for 

acknowledgements.  

• Select View>eReferrals.  

 

 

• Select a start date.  

• Select HealthLink as the Messaging 

Provider.  

  

 

 

• Select Unacknowledged for the 

status.  

 

 

If there are any messages that are not acknowledged, you will need to investigate. Please note that some 

EMRs will not acknowledge and you will need to ring the site to confirm they have received the letter and 

referral. If they have received the message, we suggest that you make a note that the site will not 

acknowledge so you will know for next time.  

False acknowledgements  
• Select a start date. 

• Select HealthLink as the Messaging Provider.  

• Select Unacknowledged for the status.  

• Tick Hide positive acknowledgements.  

• This log will list the negative acknowledged messages. This means that the messages will not have 

been sent and there was an error when exporting the outgoing message.  

• You will need to make a note of the error which appears in the Details area and the patient and go 

to the patient details, Correspondence Out, select the letter to be fixed and resend the message.  

  

  



Sending eReferrals  

Before you begin  
Please confirm the version of Best Practice you are using is Indigo or above. Confirm Practice Preferences 

and Provider Preferences  

 Practice  

• Select Setup > Configuration. 

 

 

• Click on General icon and confirm 

Online Directory for Contacts is set to 

HealthLink.  

• Click Save.  

 

 

Provider  

• Select Setup > Preferences.  

 

 



• Click on the Letters icon and confirm 

the Default address book is set to Local 

Address Book 

• Tick Display Online Directory on 

contact selection screen and click Save 

& Close.  

 

 

 

Creating and sending a new referral or letter  

• Open the Patient Clinical Record.  

• Select File>New Letter (F4) or click the new letter icon on the toolbar to create a new referral. 

• Choose an existing template that you 

would like to use from either the 

Template favorites; the Use Template 

item on the Templates menu; or by 

using the new document icon on the 

toolbar. 

 

• Once you have chosen the template, you will be prompted to search for a provider to send to. Search 

using the surname of the provider. This will search both the Local Directory (the top half of search 

screen) and the Online Directory (the bottom half of screen) for matches.  



• The provider you search for may appear 

in the local directory if you already have 

them in your local directory or in the 

online directory if they are not in your 

local address book. Highlight the entry 

and click on Use Contact. If you choose 

a provider from the online directory, they 

will be added to your local directory. 

When choosing a provider, ensure they 

have a green star. The green star 

indicates that the contact is enabled to 

receive an e-Referral.  

• For further details on how the online 

directory works please follow the below 

link: 

http://kb.bpsoftware.net/au/bppremier/ja

de/Content/General/WordProcessor/He

althLinkDirectory.htm?Highlight=online

%20directory      

 

 

• Once you have chosen the provider you will be taken back to the letter template and the details will 

prepopulate. You are also able to add text and further details to the letter or eReferral.  

 

• Once you have completed the letter or 

eReferral, click on the Export HL7 icon 

from the tool bar at the top of the page 

 

 

http://kb.bpsoftware.net/au/bppremier/jade/Content/General/WordProcessor/HealthLinkDirectory.htm?Highlight=online%20directory
http://kb.bpsoftware.net/au/bppremier/jade/Content/General/WordProcessor/HealthLinkDirectory.htm?Highlight=online%20directory
http://kb.bpsoftware.net/au/bppremier/jade/Content/General/WordProcessor/HealthLinkDirectory.htm?Highlight=online%20directory
http://kb.bpsoftware.net/au/bppremier/jade/Content/General/WordProcessor/HealthLinkDirectory.htm?Highlight=online%20directory


• A Document Detail box will now show. 

Untick Save As Draft and click Save.  

 

 

• A screen confirming that the letter has 

been successfully exported will show. 

Click OK and you will be taken back to 

the letter. From here, you can print the 

letter for the patient and then exit the 

letter.  

 

 

• The letter will be saved in the 

Correspondence Out tab.  

 

 

  

  

  

  

  

  

  

  

  

  



Checking acknowledgments  
If you are sending referrals or reports, it is important to check the recipient is actually receiving them. 

HealthLink suggests you implement an administrative routine similar to what you would already have in the 

practice for following up pathology or radiology requests. HealthLink also has a report which can be run 

daily or weekly which will show you at a ‘transport’ level what has been sent from your practice and 

acknowledged by the recipient. The Best Practice e-Referrals screen screen will give you a better patient 

and doctor-centric view. Please email helpdesk@healthlink.net if you wish to be subscribed to the report.  

Once you have sent a message, the recipient’s system should inform you - by way of an application 

acknowledgment - to let you know the referral was received successfully into the receiving practice clinical 

or practice management or triaging system. Acknowledgments are dependent on the receiving system set-

up. Therefore, please check at the end of each day to confirm that you have received an Acknowledgment. 

If you haven't received one, check the following day and if it is still not received contact HealthLink’s 

helpdesk at helpdesk@healthLink.net to confirm it for you.  

 

• To check for unacknowledged or 

unsuccessful transmission, from the 

main Best Practice screen select 

View>eReferrals.  

 

 

• Untick the Hide positive acknowledgments check box.   

• This log will list the negative and positive acknowledgements. A blank acknowledgement means the 

document may not have received. A negative acknowledgement (Status - removed) indicates the 

referral was not received or accepted at the receiving end and staff should call the receiving site to 

confirm receipt. An alternative method of delivery in this case may be required to send to the specialist 

practice or, if you printed the document for the patient, the patient will be able to present this to the 

specialist at time of booking. If the error is an ‘invalid namespace’ check the electronic address (EDI) in 

the address book and correct it before resending the referral.  

 

 

 



 Viewing incoming reports and referrals  
 Select View> Incoming Reports.  

 

 

• Tick Show unallocated only. 

• Highlight the report or letter and double click the highlighted report or letter to open and view.  

• You can print the report from here, if needed. 

• Allocate to User (doctor or nurse) or Allocate to Patient. 

 

  

  

  

  

 

 

 

  

 


